Westfalia / Erich Jäger - AHK codieren (ACC Ausfall/Problem) *gelöst* *Anleitung inside*

    • Westfalia / Erich Jäger - AHK codieren (ACC Ausfall/Problem) *gelöst* *Anleitung inside*

      Hey,
      ich rüste demnächst eine AHK nach.
      Weiß jemand zufällig wo genau ich die mit vcds dann codieren kann?
      Bei Stemei ist die Anleitung leider rausgenommen worden.

      Gruß und Danke

      Tobi

      ANZEIGE

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Chiquita ()

    • Super, erstmal vielen Dank für die Anleitung!

      Nach dem Einbau der AHK waren logischerweise erstmal sämtliche Fehler im System und das ACC inkl Tempomat funktionierte auf der Heimfahrt nicht mehr.

      Heute Abend habe ich dann die Anleitung abgearbeitet jedoch immernoch Fehlermeldungen und ACC funktioniert immernoch nicht.


      Ich schrieb:

      01-Motorelektronik -- Status: Fehler 0010
      03-Bremsenelektronik -- Status: i.O. 0000
      04-Lenkwinkelsensor -- Status: i.O. 0000
      10-Einparkhilfe 2 -- Status: i.O. 0000
      13-Distanzregelung -- Status: Fehler 0010
      14-Raddämpfung -- Status: i.O. 0000
      15-Airbag -- Status: Fehler 0010
      16-Lenkradelektronik -- Status: i.O. 0000
      17-Schalttafeleinsatz -- Status: i.O. 0000

      Adresse 01: Motorelektronik (J623-CUNA)Labeldatei: Keine
      Teilenummer SW: 04L 906 026 BSHW: 04L 907 309 R
      Bauteil: R4 2,0L EDCH23 1541
      Revision: B5H23---
      Codierung: 011D001A037405082000
      Betriebsnr.: WSC 01357 011 00200
      ASAM Datensatz: EV_ECM20TDI01104L906026BS 002003
      ROD: n.v.
      VCID: 7CFC4660F7D2B5FEC7F-8029

      Keine ASAM Daten verfügbar: "EV_ECM20TDI01104L906026BS"
      1 Fehler gefunden:
      17156 - ROD - Unbekannter Fehlercode
      - 00 [047]
      bestätigt - geprüft seit letzter Löschung
      Freeze Frame:
      Fehlerstatus: 00000001
      Fehlerpriorität: 6
      Fehlerhäufigkeit: 10
      Kilometerstand: 21119 km
      Datum: 2018.03.24
      Zeit: 19:50:41


      Readiness: 0 0 0 0 1


      Adresse 13: Distanzregelung (J428)Labeldatei: Keine
      Teilenummer SW: 5Q0 907 572 HHW: 5Q0 907 572 H
      Bauteil: ACC BOSCH MQB H10 0620
      Codierung: 35004FC151FFC428949C810530300600000000000000000000
      Betriebsnr.: WSC 01357 011 00200
      ASAM Datensatz: EV_ACCBOSCHVW416 002005
      ROD: n.v.
      VCID: 3C7C8660B75275FE87F-8069

      Keine ASAM Daten verfügbar: "EV_ACCBOSCHVW416"
      1 Fehler gefunden:
      1229 - ROD - Unbekannter Fehlercode
      - 00 [009]
      bestätigt - geprüft seit letzter Löschung
      Freeze Frame:
      Fehlerstatus: 00000001
      Fehlerpriorität: 4
      Fehlerhäufigkeit: 1
      Verlernzähler: 99
      Kilometerstand: 21119 km
      Datum: 2018.03.24
      Zeit: 20:12:56
      Hat jemand ne Idee was das sein könnte? Kann mir einer Sagen was bei den Bits steht im Byte 16 des Stg A5 Front-/Vorfeldkamera? (siehe Bild im Anhang)
      Dateien
    • Vielen Dank @TurboDiesel91

      @Sandman ich verstehe die letzte Seite deiner Anleitung nicht richtig. (siehe Anhang)

      Sandman schrieb:

      Bit0-7 01 Anhängererkennung verbaut
      Was genau muss ich denn dann da abhaken?

      Und hat einer eine Idee wo der ACC Fehler und der aus dem 01er herkommt?
      Dateien
    • 1. Auf Bild fünf Bit 0-7: Da ist doch ein Dropdownfeld in welchem auf deinem Bild steht "01 Anhängererkennung verbaut". Das sollte bei dir auch stehen.

      2. In der Anleitung die du abgearbeitet hast, hast du im Steuergerät 01 Motorelektronik Byte 5 Bit 4 "Anhängererkennung (J345) verbaut" aktiviert. Das ist bei der Nachrüst-AHK mit dem E-Satz von Erich Jäger nicht vorgesehen. Ich habe es nicht aktiviert und habe auch keine Fehlermeldung. Für mich sieht das so aus, als würde man dem Motorsteuergerät damit sagen, dass ein bestimmtes Steuergerät verbaut, welches wiederum tatsächlich nicht verbaut worden ist und damit zum Fehler führen könnte.

    • sixT9 schrieb:

      1. Auf Bild fünf Bit 0-7: Da ist doch ein Dropdownfeld in welchem auf deinem Bild steht "01 Anhängererkennung verbaut". Das sollte bei dir auch stehen.

      2. In der Anleitung die du abgearbeitet hast, hast du im Steuergerät 01 Motorelektronik Byte 5 Bit 4 "Anhängererkennung (J345) verbaut" aktiviert. Das ist bei der Nachrüst-AHK mit dem E-Satz von Erich Jäger nicht vorgesehen. Ich habe es nicht aktiviert und habe auch keine Fehlermeldung. Für mich sieht das so aus, als würde man dem Motorsteuergerät damit sagen, dass ein bestimmtes Steuergerät verbaut, welches wiederum tatsächlich nicht verbaut worden ist und damit zum Fehler führen könnte.
      1.Wie ihr seht ist da bei mir kein Dropdown.... (siehe Anhang)

      2. Okay dann werde ich das wohl nochmal rausnehmen.... :huh:

      @Sandman Nein es ist das Steuergerät von Westfalia / Erich-Jäger

      Edit: Könnte es daran liegen, dass mein Kumpel nicht auf die neueste VCDS Version aktualisiert hat?
      Dateien
    • Ich schätze schon, dass das zusammenhängen könnte.
      Ich habe die neueste Version von VCDS und da sind die Dropdownfelder vorhanden. Die Updates sind doch kostenlos. Das Update ist doch schnell gemacht. Vielleicht sollte er das noch schnell nachholen.

      ANZEIGE
    • Bei manchen Fehlern ist es nach dem Löschen auch so, dass das Fahrzeug erst noch ein paar Meter bewegt werden muss, bis die Fehler ausgehen. Also einfach nur kurze Runde fahren. Hatte ich mal beim Airbag. Nur zur Info. Kenne mich mit ACC leider nicht so viel aus.

      Wenns gar nicht geht kommst du einfach mal vorbei, dann programmiere ich dir das rein :thumbup:

      Das mit dem legalen VCDS stimmt leider. Vielleicht liegt es daran. Sieht man leider immer wieder. Keine Updates, keine korrekte Codierung.

    • Eigentlich die Verbauliste im 19er ergänzen, in der Bremselektronik die Gespannstabilisierung aktivieren, in der Einparkhilfe 2 den entsprechenden Punkt aktivieren und im 09er zentralelektrik die ahk aktivieren.

      Wie gesagt morgen (bzw. nachher) bin ich am Fahrzeug und schicke dir ne Anleitung.

      In deinem Fall eben noch zusätzlich das dropdownfeld fürs acc.

    • also 12.12.2 ist mal unter garantie nicht original.
      Werkzeug statt Spielzeug, aber is auch schön, im ACC Blind rumcodieren und in der Kamera.
      für die Kosten der Kalibrierungen geht sich das originale auch aus.

      also im eigenen Interesse, jemanden mit ordentlicher Ausrüstung und Know How aufsuchen.


      bitte nehmt mir den Post nicht übel, aber das endet doch in keiner ordentlichen Lösung.
      Zumal ich MQB Fahrzeuge eher mit Maßnahmencode bei Vw machen liesse, dann fällt die AHK nicht beim nächsten Abgleich wieder aus der Codierung.

      Golf VII 4Motion Highline Sky Limestone-Grey | Felgen Madrid
      Ab Werk: Xenon mit Kurvenlicht | Pornorama Dach | Composition Media | MuFu+GRA | Fahrprofil | PDC vo+hi | Scheiben getönt | R-Line Paket klein
      Nachgebessert: Helix System | Facelift Heckleuchten | ACC mit Front Assist | Kombiinstrument in Farbe | Discover Pro 2 | RVC High | Aircare | Lane Assist FLA VZE

      VCDS | VCP User :D

      Aktuell übrig:
      Lenkradtasten mit ACC
      1 Discover Pro Gen 2 :)
    • Nach Anbau der AHK tat mein ACC zunächst auch nicht. Trotzdem die erste Fahrt gemacht, Auto abgestellt und 5min später Motor gestartet => Fehler weg und ich konnte das ACC wieder benutzen.

      Trotzallem mein Tipp und auch der von @-Harry-: Beim VW Händler eine Codierung mit SVM Maßnahmencode durchführen lassen und alles läuft vernünftig.
      Habe es bei mri auch noch vernünftig codieren lassen. Kostenpunkt ca. 25 Euro.

    • So, hier das Video zur Codierung. Ist leider erstmal nur ein Vorabvideo ohne Ton und ohne Format. Komme erst nächste Woche dazu das Video ordentlich zu machen.

      Was grundsätzliches zur Codierung: Wenn ich etwas codiere und in einem Steuergerät die letzte Codierung ausführe, dann setze ich unten links einen Haken mit (Steuergerät neu starten). Das hilft um Probleme zu vermeiden. Man kann sich eben entscheiden ob man die Busruhe abwartet, oder das Steuergerät neu startet und danach die Zündung aus und wieder ein schaltet.

      Anleitung in Schrift:
      VCDS öffnen ->

      Steuergeräteauswahl ->
      03-Bremselektronik->
      Anpassung-10 ->
      Gespannstabilisierung raussuchen ->
      bei Neuer Wert "aktiviert" wählen ->
      Übernehmen ->
      Zurück/Schließen

      Steuergeräteauswahl ->
      09-Zentralelektrik->
      Zugriffsberechtigung-16 -> Zugriffscode 31347 eingeben ->
      Bestätigen ->
      Codierung-07 ->
      Assistent für Codierung ->
      Byte 1 auswählen ->
      Bit 1 aktivieren (Trailer Hitch Control Module installed) ->
      Schließen ->
      Bestätigen ->
      Zurück/Schließen

      10-Einparkhilfe 2 ->
      Codierung-07 ->
      Assistent für Codierung ->
      Byte 3 auswählen ->
      bei Bit 0-1 "01 Trailer Hitch installed (manually removable)" auswählen ->
      Schließen ->
      Bestätigen ->
      Zurück/Schließen

      19-Diagnoseinterface ->
      Verbauliste ->
      69-Anhänger aktivieren ->
      Übernehmen ->
      Zurück/Schließen

      Bitte bedenken: bei ACC Fahrzeugen muss noch die entsprechende Codierung im ACC Steuergerät vorgenommen werden.
      A5-Front-/Vorfeldkamera
      Codierung-07 ->
      Assistent für Codierung ->
      Byte16 auswählen->
      bei Bit 0-7 "Anhängererkennung verbaut" auswählen ->
      Schließen ->
      Bestätigen ->
      Zurück/Schließen



      @-Harry- Ich hatte mich wegen der VCDS Version auch gewundert. Mal abwarten was kommt. Ich gebe Dir auf jeden Fall recht, dass blindes Codieren nicht gut ist.

      Mit dem Maßnahmencode bin ich bedingt bei dir. Bis jetzt wurden meine Codierungen bei keinem Update überschrieben. Habe diese Erfahrung auch schon durch andere Nutzer mitgeteilt bekommen und gelesen.
      Fakt ist aber auch (und da bin ich eben bei dir), dass bei der Abarbeitung per Maßnahmencode in der Werkstatt die Veränderung in der VW Datenbank registriert wird, was es dem Service auch erleichtert bei möglicher Fehlersuche.

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von sixT9 ()

    • Soooo, es ist vollbracht.

      Ganz vollständig war deine jedoch auch nicht sixt9, daher habe ich kurzerhand bei Rameder nachgefragt.
      Diese haben mir dann diese Liste geschickt:


      Rameder schrieb:

      Codieranleitung
      1. STG 19 (Gateway) auswählen
      Verbauliste
      AHK anmelden - STG 69 aktivieren
      2. STG 01 (Motorelektronik) auswählen
      STG Codierung -> Funktion 07
      Byte 5
      Bit 4 aktivieren (Trailer installed) je nach Motorvariante unterschiedlich
      3. STG 03 (Bremsenelektronik) auswählen
      STG Anpassung
      Gespannstabilisierung aktivieren
      4. STG 09 (Bordnetz/Zentralelektrik) auswählen
      bis MJ 2016
      STG Codierung -> Funktion 07
      Byte 1
      Bit 1 aktivieren
      -oderab MJ 2017
      STG Zugriffsberechtigung -> Funktion 16
      Zugriffscode 31347 eingeben
      STG Anpassung
      ENG122979-ENG10896-Vernetzung-Anhängeranschlussgerät
      Aktuellen Wert von „nicht verbaut“ auf „verbaut“ ändern
      5. STG 10 (Einparkhilfe) auswählen
      STG Codierung -> Funktion 07
      Byte 3
      Bit 0 aktivieren (bei verbau: manuell abnehmbar)
      Bit 1 aktivieren (bei verbau: elektrisch ausfahrbar)
      6. STG 13 (ACC / Distanzregelung) auswählen
      STG Codierung -> Funktion 07
      Byte 2
      Bit 3 aktivieren
      -oderByte 3
      Bit 3 aktivieren
      7. STG A5 (Front/Vorfeldkamera) auswählen
      STG Codierung -> Funktion 07
      Byte 16
      Bit 0 aktivieren
      -oderByte 11
      Bit 0 aktivieren

      In meinem Fall (MJ 02/2017) musste ich im STG 13 bei Byte 3 Bit 3 aktivieren und im STG A5 bei Byte 11 Bit 0.

      Dann ne kleine Runde gefahren, Zündung an und aus und schon waren alle Fehler weg.


      Vielen Dank für eure Mühen!!

      Gruß Tobi
    • Sehr gut, danke fürs Posten.

      Ja wie gesagt, habe kein ACC, da wirds für mich schwer mit dem reinsehen. Auch der Modelljahrunterschied in der Zentralelektrik ist interessant.

      Wie gesagt, ich habe auch den Erich Jäger E-Satz und die wollten keine Änderung der Motorelektronik. Werde das eventuell noch mit reinnehmen oder ich habe wirklich was übersehen. Will es noch mal nachprüfen.

      Edit:
      Ich habe mir jetzt Mal eine Codierung per Maßnahmencode angesehen und da ist das Motorsteuergerät natürlich vertreten, zumindest bei einer originalen AHK.
      Danke @Chiquita

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von sixT9 ()